注意!微软宣布将停止支持多个版本的 .NET Framework

凌云时刻

微软在 .NET 博客宣布,将于 2022 年 4 月 26 日起停止支持 .NET Framework 4.5.2、4.6、4.6.1,之后微软将不再为这些版本提供更新,包括安全修复和技术支持。

据微软表示,之所以决定将不再支持这些版本,是因为它们使用了现在看来已不再安全的哈希算法 1(SHA-1)签名,而该算法容易被黑客利用以伪造数字证书去欺骗公司或窥探加密的网络会话,因此微软要淘汰使用 SHA-1 算法的 .NET Framework 版本。

在查看所有不同版本 .NET Framework 的下载和使用情况后,微软发现只要让 4.6.2 以及更高版本的 .NET Framework 的数字证书更新就可以保证约 98% 用户无需更新版本。而剩下一小部分使用 .NET Framework 4.5.2、4.6 和 4.6.1 的用户则只需要升级到 4.6.2 版本及以上即可。

基于这个发现,微软决定以 .NET Framework 4.6.2 为分界线,使用 4.6.2 之前的版本的用户,最晚要在 2022 年 4 月 26 日之前升级版本,否则如果遇到任何安全问题或需要技术支持,系统还是会要求你首先升级到支持的版本。

据了解,.NET Framework 4.6.2 在约 5 年前发布,而 .NET Framework 4.8 大约在 2 年前发布,这两个版本都是安全可靠的,也是 .NET Framework 4.5.2、4.6、4.6.1 高度兼容的替换版本,并已通过 Windows Update(WU)广泛部署到亿万台计算机中。如果你的计算机是从 WU 获取最新更新的话,那么你的应用可能已经在 .NET Framework 4.8 上运行了。

此外,为了摒弃 SHA-1 算法并提高安全性,从下个月开始微软所有的主要服务和进程(包括代码签名,文件哈希和 TLS 证书)都将只使用 SHA-2 算法。其实去年 8 月,微软就在下载中心下架了所有 Windows 签名的 SHA-1 内容,并且将 Windows 更新的签名改为使用 SHA-2 算法。

因此,为了确保安全性,请尽快更新至 .NET Framework 4.6.2 及更高版本吧!

参考链接:

https://devblogs.microsoft.com/dotnet/net-framework-4-5-2-4-6-4-6-1-will-reach-end-of-support-on-april-26-2022/

来源|CSDN

END


长按扫描二维码关注凌云时刻

每日收获前沿技术与科技洞见

投稿及合作请联系邮箱:lingyunshike@163.com

相关推荐